Hi everyone,
I have recently started my own home server and am quite proud to say that I’ve come pretty far with it - yay ![]()
Here is my problem: I have OnlyOffice (9.4.0) connected to Nextcloud (34.0.0). Both are installed with docker-compose files; and both are behind a proxy set up with Nginx Proxy Manager (incl. SSL certificates). However, when I try to open a document, I just get a black loading screen (with the white page loading animation).
I really don’t know why this is happening. The following things are working well:
- I can use and access Nextcloud fine and without any problems.
- The OnlyOffice welcome page shows up without errors (…/welcome)
- The OnlyOffice healthcheck URL returns true (…/healthcheck)
- The connector on Nextcloud returns a success message when I click Save: “Server settings have been successfully updated (version 9.4.0.129)”
However, I do see errors in the ngins.error.log from within the OnlyOffice docker container. These errors appear when I try to access /info/info.json. I tried this because I read somewhere to check this JSON for access to API endpoints. Clearly this is not working - the connection is refused. Interestingly, it is refused both from the proxy URL and also when I try to access it directly on my local LAN IP (without any SSL).
2026/06/21 06:32:57 [error] 11394#11394: *55 access forbidden by rule, client: 10.99.99.1, server: , request: “GET /info/info.json HTTP/1.1”, host: “``onlyoffice.[URL...]``”
2026/06/21 06:33:14 [error] 11394#11394: *58 connect() failed (111: Connection refused) while connecting to upstream, client: 10.99.99.1, server: , request: “GET /example/ HTTP/1.1”, upstream: “``http://127.0.0.1:3000/``”, host: “``onlyoffice.[URL...]``”
2026/06/21 06:33:14 [error] 11394#11394: *58 connect() failed (111: Connection refused) while connecting to upstream, client: 10.99.99.1, server: , request: “GET /example/ HTTP/1.1”, upstream: “``http://127.0.0.1:3000/``”, host: “``onlyoffice.[URL...]``”
2026/06/21 06:38:29 [error] 11394#11394: *82 access forbidden by rule, client: 10.99.99.1, server: , request: “GET /info/info.json HTTP/1.1”, host: “``onlyoffice.[URL...]``”
2026/06/21 07:08:22 [error] 11394#11394: *178 access forbidden by rule, client: 10.99.99.1, server: , request: “GET /info/info.json HTTP/1.1”, host: “``onlyoffice.[URL...]``”
2026/06/21 07:09:20 [error] 11394#11394: *179 access forbidden by rule, client: 10.99.99.4, server: , request: “GET /info/info.json HTTP/1.1”, host: “192.168.[URL...]”
Do you have any idea what might be the problem? I’d be so grateful for a pointer. I have browsed through endless forums, tried to adjust the Nginx Proxy Manager settings with custom configurations etc. etc. etc. But nothing is working ![]()