ubuntu server24.04
Installing ONLYOFFICE DocSpace from DEB/RPM packages v3.6.1.560
安装正常,使用正常。
但是,在关机重启后,经常性的出现编辑器不可用的情况,editor v9.2.1.8>>>>>v4.1.5.1
这是否与我的PC性能较弱有关,启动service时间较长,是否存在某些service没准备好,其他service插队的情形。能否提供service的启动顺序,我再手工试试,谢谢。
您好 @sxw2sxw!
感谢您的详细反馈!
-
系统资源是否满足最低要求
请参考官方最低系统要求(DocSpace + Document Server):
Installing ONLYOFFICE DocSpace Community using the provided script- CPU:至少 6核(推荐 8核)
- RAM:至少 12 GB(推荐 16 GB)
- HDD:至少 40 GB 可用空间
- Swap:至少 6 GB
- OS:amd64 架构的 Linux,内核版本 3.10 或更高
-
查看日志,定位具体错误
请提供以下日志文件的内容(或其中明显的错误部分):- /var/log/onlyoffice/docspace/ 目录下的主要日志
(尤其是 ds、files、api、studio 等服务的日志)
- /var/log/onlyoffice/docspace/ 目录下的主要日志
-
录制问题复现视频
目前我们还不太清楚具体出错的时机和表现形式。如果方便的话,能否录一段简短的视频(比如 30秒–1分钟:
这些信息能帮助我们更快定位问题。非常感谢您的配合!
祝好!
感谢您的邮件回复。
现问题已得到解决。主要原因为硬件性能弱,导致服务启动时间匹配出现了偏差,解决如下
1.opensearch.service启动失败
解决方法:
vim /usr/lib/systemd/system/opensearch.service
# Allow a slow startup before the systemd notifier module kicks in to extend the timeout
TimeoutStartSec=150
2.ds-docservice.service启动部分失败,提示如下:
Feb 10 07:48:45 onlyoffice sh[1184]: at TCPConnectWrap.afterConnect [as oncomplete] (node:net:1611:16)
Feb 10 07:48:46 onlyoffice sh[1184]: [2026-02-10T07:48:46.869] [WARN] [localhost] [docId] [userId] nodeJS - sqlQuery error sqlCommand: SELECT column_name as "column_name" FROM informati: Error: connect ECONNR>
Feb 10 07:48:46 onlyoffice sh[1184]: at /snapshot/server/DocService/node_modules/pg-pool/index.js:45:11
Feb 10 07:48:46 onlyoffice sh[1184]: at process.processTicksAndRejections (node:internal/process/task_queues:95:5)
Feb 10 07:48:46 onlyoffice sh[1184]: [2026-02-10T07:48:46.874] [ERROR] [localhost] [docId] [userId] nodeJS - getTableColumns error: Error: connect ECONNREFUSED ::1:5432
Feb 10 07:48:46 onlyoffice sh[1184]: at /snapshot/server/DocService/node_modules/pg-pool/index.js:45:11
Feb 10 07:48:46 onlyoffice sh[1184]: at process.processTicksAndRejections (node:internal/process/task_queues:95:5)
Feb 10 07:48:46 onlyoffice sh[1184]: [2026-02-10T07:48:46.875] [WARN] [localhost] [docId] [userId] nodeJS - sqlQuery error sqlCommand: SELECT column_name as "column_name" FROM informati: Error: connect ECONNR>
Feb 10 07:48:46 onlyoffice sh[1184]: at /snapshot/server/DocService/node_modules/pg-pool/index.js:45:11
Feb 10 07:48:46 onlyoffice sh[1184]: at process.processTicksAndRejections (node:internal/process/task_queues:95:5)
lines 20-69/69 (END)
解决方法第一步:
vim /usr/lib/systemd/system/ds-docservice.service
[Unit]
Description=Docs Docservice
After=network.target syslog.target redis-server.service ds-metrics.service rabbitmq-server.service postgresql.service
Wants=redis-server.service ds-metrics.service rabbitmq-server.service postgresql.service
再启动,提示:
Feb 10 09:10:50 oo sh[1529]: Something went wrong installing the "sharp" module
Feb 10 09:10:50 oo sh[1529]: EACCES: permission denied, mkdir '/var/www/onlyoffice/documentserver/.cache/pkg/282c93e4113a05841f827943c9f6cd6d4188bfda819ab5>
Feb 10 09:10:50 oo sh[1529]: Possible solutions:
Feb 10 09:10:50 oo sh[1529]: - Install with verbose logging and look for errors: "npm install --ignore-scripts=false --foreground-scripts --verbose sharp"
Feb 10 09:10:50 oo sh[1529]: - Install for the current linux-x64 runtime: "npm install --platform=linux --arch=x64 sharp"
Feb 10 09:10:50 oo sh[1529]: - Consult the installation documentation: https://sharp.pixelplumbing.com/install
Feb 10 09:10:54 oo sh[1529]: [2026-02-10T09:10:54.217] [WARN] [localhost] [docId] [userId] nodeJS - Express server starting...
Feb 10 09:10:54 oo sh[1529]: [2026-02-10T09:10:54.423] [WARN] [localhost] [docId] [userId] nodeJS - notifyLicenseExpiration(): expiration date is not defin>
Feb 10 09:10:54 oo sh[1529]: [2026-02-10T09:10:54.424] [WARN] [localhost] [docId] [userId] nodeJS - notifyLicenseExpiration(): expiration date is not defin>
Feb 10 09:10:55 oo sh[1529]: [2026-02-10T09:10:55.331] [WARN] [localhost] [docId] [userId] nodeJS - Express server listening on port 8000 in production-lin>
解决方法第二步:
sudo chown -R ds:ds /var/www/onlyoffice/documentserver/
sudo chmod 755 /var/www/onlyoffice/documentserver
sudo mkdir -p /var/www/onlyoffice/documentserver/.cache
sudo chown -R ds:ds /var/www/onlyoffice/documentserver/.cache
sudo chmod 755 /var/www/onlyoffice/documentserver/.cache
3.ds-converter.service 启动部分失败
vim /usr/lib/systemd/system/ds-converter.service
[Unit]
Description=Docs Converter
After=network.target syslog.target redis-server.service ds-metrics.service rabbitmq-server.service postgresql.service
Wants=redis-server.service ds-metrics.service rabbitmq-server.service postgresql.service
1 Like